Tuesday, October 12, 2010

Solution: Can't Browse the Internet After Installing / Upgrading AVG Anti-virus | How to Remove AVG Miniport

Problem:
Can't browse the Internet after installing or upgrading AVG 9.0

Symptoms:
  1. In some system, Local Area Connection (LAN) says the cable is unplugged even though it is plugged in.
  2. IPConfig command returns nothing.
  3. In the Device Manager under Network Adapters, there are several entries of AVG miniport driver and these entries have yellow exclamation mark. ("WLAN Miniport (IP) - AVG miniport driver")
  4. Properties shows: "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19) Click Troubleshoot to start the troubleshooter for this device."
  5. You cannot uninstall the AVG miniport driver entries (remove or delete). Update and rollback doesn't work either. System Restore will not help.
Screenshot:

Culprit:
The devices appear because they are called up by registry entries which should have been deleted as part of the AVG uninstallation

Solution:
Uninstall your network adapter (the one without exclamation mark) and install it again. This usually solves the internet connection issue but the AVG miniport driver entries still exists.

How to remove AVG miniport driver entries in Device Manager:
Try any of the following solutions:
  1. Go to Network Connections and disabled then re-enabled Firewall protection for your network connection.
  2. Download and use AVG remover. It is a cleanup utility provided by AVG to remove any trace of AVG antivirus.

1 comment:

plydia61 said...

awesome. it worked perfectly, thank you!